Are .logicdata files Backward and Forward Compatible?

Compatibility with the Logic 2.x software

Unfortunately, .logicdata files saved in Logic 1.x are not compatible with Logic 2.x. The Logic 2.x software uses a new .sal file format. Several users have expressed their need for .logicdata compatibility in Logic 2.x in an idea post here. Feel free to add your votes/comments to it!

Compatibility with the Logic 1.x softaware

.logicdata files are forward compatible within Logic 1.x. That means that files saved with older versions of the Logic 1.x software can be opened by newer versions of the Logic 1.x software. However, backward compatibility is not supported. You cannot open newer files with other versions of the software.